Tag Archives: chromium

Chrome/Chromium with GPU acceleration

Chromium just switched on GPU acceleration. There was a changeset in the source tree a few hours ago causing some test failures, prompting me to check what interesting development was happening. Apparently they changed the command-line switch needed to enable GPU acceleration, which seems to indicate that they wanted it enabled by default. This is likely a reaction to yesterday’s Slashdot coverage on GPU acceleration in web browsers.

Image showing Chromium automated test results with more than 20 failures

The first thing I noticed when using this Chromium build was its bugginess. As in crash-your-tabs buggy. There were quite a lot of test failures caused by the change.

The other problem could only be seen in pages with HTML5 Video (and most likely Canvas as well): the text in these pages looked blurry.

Image showing blurry font rendering

Compare with normal rendering:

Image showing sharp font rendering

(Update: r59324 has been reverted, so no GPU acceleration for now.)
(Update (2010-09-18): Looks like it’s back. I haven’t noticed any particular instabilities, so that’s great. Blurry fonts I can manage; that’s also how Firefox nightly looks like, and I’m starting to suspect my graphics driver.)

At least now we know that GPU acceleration in Chromium is not ready yet. At least now I know that whatever technique these browsers use to render pages with GPU doesn’t sit well with mine (an Intel chip).

Advertisements

User agent madness

Have you seen Chrome/Chromium’s user agent string?

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.8 (KHTML, like Gecko) Chrome/5.0.394.0 Safari/533.8

I’m surprised they didn’t throw IE and Opera in there as well, for good measure.

I know of the compatibility arguments, but really, this is absurd.

Update (2010-05-26): Compare with Midori’s UA string:

Midori/0.2 (X11; Linux; U; en-us) WebKit/531.2+